Ediscovery Interruption

Incident Report for Disco Status Page

Resolved

DISCO experienced an interruption on 10/27 impacting Ediscovery. Thank you for your patience.
Posted Oct 27, 2025 - 18:03 CDT

Monitoring

Ediscovery is online - A solution has been implemented and Engineering is monitoring the results. The interruption was fixed at 17:02 CDT.
Posted Oct 27, 2025 - 17:30 CDT

Investigating

DISCO is currently experiencing an interruption in United States impacting Ediscovery. Engineering is aware and is investigating the interruption actively.
Posted Oct 27, 2025 - 17:00 CDT
This incident affected: USA (Ediscovery).